1. Ce site utilise des "témoins de connexion" (cookies) conformes aux textes de l'Union Européenne. Continuer à naviguer sur nos pages vaut acceptation de notre règlement en la matière. En savoir plus.

Problème avec 1&1

Discussion dans 'Problèmes' démarrée par Freddy44, 17 Septembre 2017.

  1. Freddy44
    Offline

    Freddy44 Novice

    Inscrit depuis le :
    17 Septembre 2017
    Messages :
    2
    "J'aime" reçus :
    0
    Points de Trophée :
    1
    Lieu de résidence :
    Vallet
    Bonjour,

    Mon fils a récemment utilisé Extaz sur AllsHeberge. Nous l'avons migré sur un serveur 1&1.
    Impossible de le faire fonctionner depuis.

    Nous arrivons sur une erreur 500, internal server error. Après discussions avec les IT de 1&1, nous avons viré les .htaccess pour faire un test. Nous n'arrivons toujours à rien.
    Nous avons réinstallé une version Extaz from scratch, essayé de passer en php 7.0 => erreur.
    essayé avec php 5.6 => affichage complètement foireux (genre comme si on n'avait pas les .css...)

    Auriez-vous une petite piste, parce que nous n'avons plus tellement d'idée.
    Il s'agit de olirion.fr, si vous voulez jeter un coup d'oeil.

    La config actuelle :
    htdocs/.htaccess => renommé en, .htaccessold
    htdocs/app/.htaccess => renommé en, .htaccessold
    htdocs/app/webroot/.htaccess => renommé en, .htaccessold

    Le domaine pointe sur htdocs.
    Version de php : 5.6

    Impossible de trouver le php.ini dans le serveur (il n'y a que php4.4, 5.2, 5.4, 5.5, 6 dans /usr/lib/), mais sur l'interface web, voici ce qu'ils indiquent :

    Option de configuration
    PHP (5.6 et 7.0)
    allow_url_fopen : Activé
    display_errors : Activé
    html_errors : Activé
    log_errors : Désactivé
    magic_quotes_runtime : Non pris en charge
    magic_quotes_sybase : Non pris en charge
    max_execution_time : 40
    memory_limit : 81M
    post_max_size : 64M
    safe_mode : Désactivé
    upload_max_filesize : 64M

    Zend Framework : v3.0.0 pour php7.0 et v2.6.0-dev pour php5.6
    include_path .:/usr/lib/php7.0 pour php7.0 et .:/usr/lib/php5.6 pour php5.6

    Cordialement,
    Freddy
     
  2. REGDYLAN
    Offline

    REGDYLAN Support Membre de l'équipe Support

    Inscrit depuis le :
    21 Juillet 2017
    Messages :
    33
    "J'aime" reçus :
    3
    Points de Trophée :
    8
    Sexe :
    Masculin
    Travail/Loisirs :
    Etudiant en COM
    Lieu de résidence :
    Lille
    Page d'accueil :
    Bonjour @Freddy44,

    Effectivement beaucoup de problème avec 1&1..

    D'abord assurez vous d'être en version 5.6 de php

    Ensuite, essayez cette manipulation;

    A la racine de votre CMS donc "/dossierdevotrecms/" éditez le fichier .htaccess en remplaçant par ceci:

    CODE:
    <IfModule mod_rewrite.c>

    Options +FollowSymLinks
    RewriteEngine on
    RewriteBase /harmonia/
    RewriteRule ^$ app/webroot/ [L]
    RewriteRule (.*) app/webroot/$1 [L]
    </IfModule>

    Ensuite, dans le dossier "/dossierdevotrecms/app/" éditez le fichier .htaccess en remplaçant par ceci:

    CODE:
    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on
    RewriteBase /harmonia/
    RewriteRule ^$ webroot/ [L]
    RewriteRule (.*) webroot/$1 [L]
    </IfModule>

    Puis, dans le dossier "/dossierdevotrecms/app/webroot" éditez le fichier .htaccess en remplaçant par ceci:

    CODE:
    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine On
    RewriteBase /harmonia/
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^ index.php [L]
    </IfModule>

    Dites en nous des nouvelles.

    A bientôt,
    REGDYLAN
     
  3. Freddy44
    Offline

    Freddy44 Novice

    Inscrit depuis le :
    17 Septembre 2017
    Messages :
    2
    "J'aime" reçus :
    0
    Points de Trophée :
    1
    Lieu de résidence :
    Vallet
    Bonjour,

    les changement que vous avez proposer n'ont rien changer :
    Les .htaccess (du moins celui qui se trouve dans le dossier de base) quand ils ne sont pas renommer l’accès au site est impossible :
    "500 Internal Server Error".

    Je ne sais donc pas si votre manipulation a marcher. Auriez vous une solution pour que l'ont puisse mettre les .htaccess sans avoir cette erreur ?
    Sur le site olirion.fr vous pouvez voir l’erreur en question.

    Cordialement,
    Milomane (le fils de Freddy)
     
  4. Servius Tullius
    Offline

    Servius Tullius Administrateur Membre de l'équipe Administrateur Graphiste

    Inscrit depuis le :
    18 Octobre 2015
    Messages :
    546
    "J'aime" reçus :
    97
    Points de Trophée :
    43
    Sexe :
    Masculin
    Lieu de résidence :
    France
    Page d'accueil :
    Bonjour,
    Avez vous pensé à mettre les dossiers et fichiers du CMS en CHMOD 755 ? Si ce n'est pas le cas, merci de faire ceci est de tester à nouveau.
    Aussi pouvez vous nous communiquer les logs erreurs de votre site. Et quelle version de ExtazCMS utilisez vous ?

    Cordialement.
     

Partager cette page

Utilisateurs qui regardent actuellement cette discussion : 0 membre(s) et 0 visiteur(s)